Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-31-2003, 01:33 PM
Posts: n/a
electrical problem: hazard relay

i have a simple electrical problem to solve.

1. the hazard warning lights don't flash. the indicators work fine but when i turn on the hazards the relay makes a loud squawking noise. is this a sign of a faulty relay or something wrong with the switch itself?

thanking you in advance for your help.

the old girl just gets better and better!
Reply With Quote
Old 05-31-2003, 04:06 PM
Registered User
Join Date: Apr 2002
Location: Surrey, Uk
Posts: 254
Same relay does both jobs so it is probably OK. I would start with the hazard switch itself then the wiring.
Mick J
'08 Chrysler 300CRD (MB OM 642 engine)
'95 E220 estate
'89 230TE (R.I.P.)
Reply With Quote
Old 06-01-2003, 05:13 AM
Posts: n/a
many thanks,
i'll have a another go at it on monday and let you know how it works out.
Reply With Quote
Old 06-02-2003, 03:31 PM
Posts: n/a
thanks for your help, it was indeed the switch. the arms inside the red plastic rocker had broken.

my car is now working perfectly! just need to find some leather seats for it now.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:55 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page