Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-04-2003, 02:22 PM
Registered User
 
Join Date: Mar 2003
Location: Carmel, CA
Posts: 301
Unhappy Acceleration and warning lights!!!

Whats wrong? Ok, under medium to hard acceleration in my 1991 300SL the battery warning light comes on. Why is this happening and how do I fix it.

Thanks in advance!!

Allan
__________________
1973 280 - Sold
1980 300SD - Sold
1982 240D - Stolen
1988 300E - Sold
1989 260E - Sold
1989 560SEL
1994 E420 - Sold
1997 E420
2005 CL500
Reply With Quote
  #2  
Old 06-04-2003, 02:29 PM
moparmike's Avatar
You will rue this day...
 
Join Date: May 2003
Location: NW Arkansas
Posts: 732
I assume you have checked and tightened all your connections? Are they free of corrosion and making full contact with the terminal? Is there a battery strap on your model? Also, check the fluid level in your battery, just to make sure that it is not sloshing.

I am no mercedes expert, but these are the first things I would check in any car that exhibited these symptoms.

good luck,
Reply With Quote
  #3  
Old 06-04-2003, 03:53 PM
Registered User
 
Join Date: Mar 2003
Location: Carmel, CA
Posts: 301
Anyone else have some input on this?
__________________
1973 280 - Sold
1980 300SD - Sold
1982 240D - Stolen
1988 300E - Sold
1989 260E - Sold
1989 560SEL
1994 E420 - Sold
1997 E420
2005 CL500
Reply With Quote
  #4  
Old 06-04-2003, 10:32 PM
Registered User
 
Join Date: Mar 2003
Location: Milwaukee Wisconsin
Posts: 1,149
You don't mention your mileage, but if it's "up there", I'd check the brushes on the alternator for wear. I believe it's an assembly ( VR module ) which can be removed and changed fairly easily. Along the same line, a loose alternator belt could be slipping. I have a 1991 300SL and found I had a badly corroded cable at the positive battery terminal. The corrosion was under the black plastic insulation, so it wasn't apparent to visual inspection. Tod
__________________
Resistance is Futile.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page