Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-10-2000, 10:57 PM
akry's Avatar
W140 Maniac
 
Join Date: May 1999
Location: Burnaby, BC, Canada
Posts: 960
When I was driving today, I notice, when leave my turn signals on, the warning lights/guages go wacky on occasion, for brief period(lasts only a sec or 2, but with uneven intervals of happening). Guages reset themself, All the warning lights will light up and gone, leave "wearing seat belt" lights flash for 3 times, then everything goes back to normal when the turn signal is off.

Any ideas??

------------------

  • 1992 Mercedes-Benz 400SE
  • Moonstone Grey/Black Leather


ICQ#26950002
Mercedes Owners ICQ ActiveList ID#61730549
http://drive.to/akry
http://akry.homestead.com
Reply With Quote
  #2  
Old 03-11-2000, 12:06 AM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Most MB dashes continue the ground circuit from cluster to cluster through contact; one unit is assembled over the next. Loosening and retightening the rear assembly often fixes the problem. If not the problem is still probably in the mutual ground circuit somewhere on the board.

------------------


[This message has been edited by Webmaster (edited 03-14-2000).]
Reply With Quote
  #3  
Old 03-11-2000, 09:29 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Even though the dash looks like a normal dash it's actually an electronic dash. There is a "mother board" that goes bad & causes the lights to flash. MB offered a rebuilt board a one time but now you must buy a complete instrument cluster.
Several aftermarket electronic repair shops are trying to offer rebuilt exchange boards but cores are hard to find.
Reply With Quote
  #4  
Old 03-11-2000, 12:21 PM
akry's Avatar
W140 Maniac
 
Join Date: May 1999
Location: Burnaby, BC, Canada
Posts: 960
DOC,

So, is there any downside if I leave it as it?? Or should I replace it ASAP?? It just started to go wacky yesterday, and only on occasion.....

Also, how much is the cluster costs on average??

Thnx DOC.

Andy Kuo

------------------

  • 1992 Mercedes-Benz 400SE
  • Moonstone Grey/Black Leather


ICQ#26950002
Mercedes Owners ICQ ActiveList ID#61730549
http://drive.to/akry
http://akry.homestead.com
Reply With Quote
  #5  
Old 03-11-2000, 02:10 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844

Sorry, I mis-read your original post as to body type. My original comments about cluster construction wouldn't apply to 140 chassis cars. The problem likely could be corrected internally, but I'm pretty sure those clusters have no internal pieces available through MB.

We just repaired a cluster on a C280 with a sticking speedo meter movement and none of the pieces were available through MB or VDO. The whole unit for that car was near $800. We found a used meter movement from one of our VDO suppliers.

The only long term problem I can think of would involve spiking the odometer prom from a bad ground circuit. Since the factory repair to either condition would be the same, I don't see any problem with ignoring it.



------------------
Steve Brotherton
Owner 24 bay BSC
Bosch Master, ASE master L1
26 years MB technician
Reply With Quote
  #6  
Old 03-12-2000, 09:17 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Only downside is what you're seeing now, sometimes other gauge problems pop-up.
MB has "rebuilt" exchange units for about $900.
Reply With Quote
  #7  
Old 03-12-2000, 11:16 PM
akry's Avatar
W140 Maniac
 
Join Date: May 1999
Location: Burnaby, BC, Canada
Posts: 960
I was driving today(raining), and notice that wiper will also cause it to go wacky....but, again, it's occasionally....

Speedometer, and techometer seems un-affected, but fuel guage, oil pressure, economic guage, and outside temp display will reset themselves(1 sec), then back to normal...

Andy Kuo

------------------

  • 1992 Mercedes-Benz 400SE
  • Moonstone Grey/Black Leather


ICQ#26950002
Mercedes Owners ICQ ActiveList ID#61730549
http://drive.to/akry
http://akry.homestead.com
Reply With Quote
  #8  
Old 03-13-2000, 09:46 PM
akry's Avatar
W140 Maniac
 
Join Date: May 1999
Location: Burnaby, BC, Canada
Posts: 960
Took my car in today. Dealer hasn't find anything wrong with the cluster yet, but they are going to change those worn engine mount. Now I am Benz-less(leave the car over-night), and hope they find the problem with the dash tomorrow....

Thnx for all the tips....

Andy Kuo

------------------

  • 1992 Mercedes-Benz 400SE
  • Moonstone Grey/Black Leather


ICQ#26950002
Mercedes Owners ICQ ActiveList ID#61730549
http://drive.to/akry
http://akry.homestead.com
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wacky fuel gauge Habanero Diesel Discussion 6 09-10-2003 03:49 AM
16v wacky wiper wierdness jasondew Tech Help 1 04-30-2003 12:51 AM
Lawyers are a wacky bunch... BENZ-LGB Off-Topic Discussion 7 03-27-2003 12:19 AM
wacky tach zeggate Tech Help 1 08-22-2002 11:46 PM



All times are GMT -4. The time now is 12:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page