Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-09-2003, 09:39 PM
Senior Member
Join Date: Mar 2001
Location: Accokeek, MD
Posts: 683
Question for Gilly

Gilly... My 1987 300E has begun to die on me when traveling down the highway. I simply lose all power and the car coasts to a stop. When trying to restart... the engine turns over well but it will not immediately start. Yet after sitting for a few minutes the car will start again without difficulty and run like a top untill it descides to die again which may be a day later.

Any suggestions where I might look for the problem? I just replaced the fuel filter but it just died on me once again after replacing the filter.


1993 190E 2.3
2000 Toyota 4x4 Tundra
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:00 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page