Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-10-2003, 04:08 PM
Registered User
Join Date: Mar 2003
Location: Montana
Posts: 65
?? on 1984 SEL fusebox / relay

Troubleshooting and correcting PO errors, here. attached is pic of my fusebox and apparently a missing relay. My CD manual has a reference for the relays and locations but the references are unreadable. erratic idle / rich at low rpms I think there is a idle speed stabilization relay somewhere.

PO had removed the relay and replaced with 30A fuse- the two blue wires in the photo. Can anybody tell me what is supposed to go in that location?

Appreciate it !!
Attached Thumbnails
?? on 1984 SEL fusebox / relay-fb-relay-quest11.jpg  

1984 500 SEL [131K]-
1991 GMC Sierra 4X4 XC [162K]- War Pony.
2004 Jeep Liberty Limited [8k]- wife's sled- Belle.
Reply With Quote
Old 06-10-2003, 04:32 PM
sixto's Avatar
smoke gets in your eyes
Join Date: Jun 2000
Location: SF Bay Area
Posts: 18,745
Based on the CD manual diagram for an 85, my guess is low speed fan relay. The idle stabilization relay would be the one behind it.

95 S420
91 300SE
87 300SDL
83 300SD
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 03:15 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page