Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-11-2003, 09:53 AM
Registered User
 
Join Date: Oct 2000
Posts: 27
Engine stalls at idle with AC

Sirs,
On my 85 500sel the engine runs as new when warmed for about 4-5 min and ok when cold after an initial hesitation when comming from idle. Also, engine snuffs sometimes at idle speen with AC on. Any thoughts about what small expensive valve may be the problem (190,000 miles)
Thanks
__________________
freddie
Reply With Quote
  #2  
Old 06-11-2003, 09:55 AM
I told you so!
 
Join Date: Jun 2002
Location: Motor City, MI
Posts: 2,791
Try cleaning the throttle body bore.
__________________
95 E320 Cabriolet, 140K
Reply With Quote
  #3  
Old 06-13-2003, 09:42 PM
Registered User
 
Join Date: Oct 2000
Posts: 27
I used carb & choke cleaner to spray in to the body. It did remove the dirt on top of the plate and the rpm increased at idle but the problem still exist. Do I need to to a more complete clean?
Thanks
__________________
freddie
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page