Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-21-2000, 01:41 PM
Posts: n/a
My 1989 300E has begun stalling while idling in gear. In park or neutral the idle is at 800rpm and there are no issues. When I am stopped at a light in drive the idle falls to 500rpm and stalls occasionally. I have replaced the plugs, distributor cap, and rotor. Any ideas??

Reply With Quote
Old 03-21-2000, 06:23 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Two things I have seen on this one. The overvoltage relay will cause this, and there was an idle modification that was on the SI updates/
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help 86 300E ignition problem jmyers177 Tech Help 4 01-23-2005 10:24 PM
1989 30SEL stalling problem jermdog11 Tech Help 3 07-20-2004 07:54 AM
300E Difficult Hot Starts Problem Solved elkadi Tech Help 5 08-28-2002 10:48 PM
300e hot start problem Tom Garrison Tech Help 4 08-14-2002 09:21 AM
300E Stalling Problem during low fuel T. Aitkin Tech Help 8 05-03-2002 01:25 AM

All times are GMT -4. The time now is 07:33 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page