Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-18-2003, 01:08 PM
Quentin Mosier
Guest
 
Posts: n/a
Question Poor Acceration , before & After ,tune-up


Recently I performed a normal tune up on My 1986, 190E 2.3.
I replaced the plugs, wires,Rotor and Distribtor Cap.
This was done with the hope of improving accceration
performance. I have not notice a great deal of change
before and after tune-up. Is there some other part that
should be changed. Air filter and oil change were also performed.
The engine does not appear to be using any oil. But seems sluggish upon take off.
Reply With Quote
  #2  
Old 06-18-2003, 02:14 PM
Registered User
 
Join Date: Feb 2003
Location: Ontario, Canada
Posts: 3,160
Have you done the fuel filter ?
__________________
2007 C 230 Sport.
Reply With Quote
  #3  
Old 06-18-2003, 03:26 PM
Registered User
 
Join Date: Aug 2002
Location: Central Asia
Posts: 104
Try adding a bottle of injector cleaner. It might clean some fuel lines and save some fuel. How much gas is your car using?
__________________
1989 230E, 8v, 166.000 km, updated to 94/95 trunk & hood
2002 Daewoo Nexia 50.000 km
Sold:
1987 VW Jetta GLE 16V, Recaro seats
1982 Volvo 240 DL (lovely car!)
and few more american cars.
Reply With Quote
  #4  
Old 06-19-2003, 03:15 PM
Quentin Mosier
Guest
 
Posts: n/a
Re: Poor Acceration , before & After ,tune-up

Quote:
Originally posted by Quentin Mosier

Recently I performed a normal tune up on My 1986, 190E 2.3.
I replaced the plugs, wires,Rotor and Distribtor Cap.
This was done with the hope of improving accceration
performance. I have not notice a great deal of change
before and after tune-up. Is there some other part that
should be changed. Air filter and oil change were also performed.
The engine does not appear to be using any oil. But seems sluggish upon take off.
Have not replaced the fuel filter but will give it a try. The injector
cleaner also sounds like a good idea. Thanks in advance for your prompt response. Will let you know if this has help my problem.
Reply With Quote
  #5  
Old 06-26-2003, 02:49 AM
190ebenz's Avatar
Registered User
 
Join Date: May 2003
Location: San Diego, CA
Posts: 8
sluggishness

I also have a 190e (2.6 ver) that is sluggish when taking off. for me it's not always but happens here and their when i'm driving.

plug/wires/fuel fltr/techron(2bottles)/oil chng/tran oil chg -diff oil chg/ changed

I'm also anxiously watching this post and want to know what's up with this!
Reply With Quote
  #6  
Old 06-26-2003, 11:09 AM
Registered User
 
Join Date: Jul 2001
Location: SoCal
Posts: 1,303
2nd gear start, maybe? Is it better if you shift into '2' first then back to 'D'?

Steve
__________________
'91 MB 190E 2.3
'08 RAV4 Ltd 3.5
'83 Lazy Daze m'home 5.7
Reply With Quote
  #7  
Old 06-26-2003, 04:37 PM
inspector1
Guest
 
Posts: n/a
You're forgetting the obvious, the O2 sensor.Possibly air control sensor.
Reply With Quote
  #8  
Old 07-11-2003, 12:37 PM
Quentin Mosier
Guest
 
Posts: n/a
Re: Poor Acceration , before & After ,tune-up

Quote:
Originally posted by Quentin Mosier

Recently I performed a normal tune up on My 1986, 190E 2.3.
I replaced the plugs, wires,Rotor and Distribtor Cap.
This was done with the hope of improving accceration
performance. I have not notice a great deal of change
before and after tune-up. Is there some other part that
should be changed. Air filter and oil change were also performed.
The engine does not appear to be using any oil. But seems sluggish upon take off.
Update after adding injector cleaner and new fuel filter. It appears that the performance has improved significantly believe
it to be the fuel filter replacement that has made the difference.
Thanks again for the assist.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page