Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-20-2003, 03:11 PM
Registered User
Join Date: Oct 2001
Location: Dallas, TX
Posts: 29
'90 300E Driver's Side Lock Actuator Sticking?


I've been having problems with my drivers side locking system. First, the door lock is very very hard to depress sometimes from the inside (other times it's easy.) Second, my alarm has been going off randomly. After reading the various posts on the topics here, I replaced the door lock cylinder thinking the microswitch was bad. However, I still have the problem occasionally that when I open the car from the drivers side, the alarm goes off either when I start the car or when I begin to drive. I have to turn off the alarm by using the key in the outside lock. Other times, it works fine.

I am wondering if the sticking of the lock is the actuator or a vacuum leak (which I assume it may be after doing a search here) but can a faulty actuator influence the alarm system? The alarm never goes off when I open the door, only when I start the car, so I assume the lock cylinder is not the problem.

Does anyone have any ideas? Thank you in advance for your help and expertise!

Don Drake

1990 300E 125k Miles
1994 S420 100k Miles
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:41 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page