Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-23-2003, 08:30 AM
Registered User
Join Date: Aug 2002
Location: Home of Elvis
Posts: 10
Central Locking 190E

I have a 1986 190E that the central locking will not work from the trunk. The system works from both doors. Also, as the locks are opening the car makes a sound similar to Chewbacca from Star Wars. The locks open slowly. Does this indicate a failing Vacuum pump. Thanks in advance for any help.
Reply With Quote
Old 06-23-2003, 09:46 AM
Registered User
Join Date: Jul 2001
Location: SoCal
Posts: 1,303
You need to localize the sound - the pump is encased in thick foam under the rear seat bottom. If the sound is elsewhere, it is probably an air leak.

Reply With Quote
Old 06-23-2003, 01:05 PM
Registered User
Join Date: Jan 2002
Location: England
Posts: 1,841
I never really liked star wars, but I think I know the sound you mean - it's normal, and the slow opening is common at this age. The lock on the trunk is very easy to get to, you could have a poke about at the actuator there to check it's working.
NB the earlier models (85?) didn't have trunk actuation - are you sure your car should have it?

2.5-16v 1990 90,000m Astral Silver
2.0E 8v 1986 107,000m Black 2nd owner
Reply With Quote
Old 06-23-2003, 02:45 PM
Registered User
Join Date: Aug 2002
Location: Home of Elvis
Posts: 10
Yes I am sure that the trunk has an actuator. But you have given me sonething else to look at. I found a replacement for the actuator at $ 20. For that price it is worth it to try. Is it fairly common for an actuator to go bad considering the age of my car?
Reply With Quote
Old 06-23-2003, 02:54 PM
Registered User
Join Date: Sep 2002
Location: NE
Posts: 133

tnbenz I just took out my pump two days ago (posted on it too, good advice there for accessing pump...). Don't know if it was bad or good but it seemed to turn on an aweful lot and was draiing my battery, which may have had nothing to do with the pump itself. offer still stands, pay for postage and one PBR and it's yours if you'd like.

1985 190e 2.3
Reply With Quote
Old 06-23-2003, 05:17 PM
Registered User
Join Date: Aug 2002
Location: Home of Elvis
Posts: 10
Based on what I have discovered after reading the posts I believe the noise problem is related to the actuators not the vacuum pump. Both actuators are noisy and the one for the fuel cap cover sticks occassionally. But my real quest is to have the central locking work from the trunk and lock the doors and the trunk. Is this also related to the actuator problem? Thanks to all for your help.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:15 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page