Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-23-2003, 02:17 PM
Registered User
Join Date: Jul 2002
Posts: 197
W126 Blower Motor

I have an 89 300se. I have had the car about a year and the air/heat has always blown, but not blown very hard. Last fall, I had the brushes replaced and at that time the armature looked fine. The mechanic admitted that the fan did not blow really as hard as it should have. We never dug into it to resolve. I have since purchased my second benz(420sel) and had to replace the blower motor because it was completely worn out. The fan on the 420 blows about 3-4 times as hard as my 300. Could the armature be worse than expected or could the blower motor itself just be worn out? Any help would be appreciated. Thanks. Scott
Reply With Quote
Old 06-23-2003, 05:42 PM
sixto's Avatar
smoke gets in your eyes
Join Date: Jun 2000
Location: SF Bay Area
Posts: 18,745
Seems like you have to dive into the blower controller and check voltages.

You might try swapping blower assemblies (a few screws) and if anything changes.

95 S420
91 300SE
87 300SDL
83 300SD
Reply With Quote
Old 06-23-2003, 06:17 PM
Registered User
Join Date: Aug 2002
Location: La Quinta, CA
Posts: 271

Could the armature be worse than expected or could the blower motor itself just be worn out?
Another possible cause is that the contacts behind your dash control fan button/s may not be making good contact. I am pretty sure you can take the dash unit out and clean and/or re-solder the contacts. Or if that is the problem you can replace the entire unit but that is expensive.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:56 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page