Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-02-2003, 02:18 AM
Registered User
 
Join Date: May 2003
Location: Rockville, MD
Posts: 96
87 420 Defroster Switch Shows ON All The Time

On my 87 420, the rear window defroster switch is lit up (as though the defroster is ON) all the time. I changed/pulled the fuses and even pulled the relay and the switch is still on all the time. When I flip the switch on and off, the interior lights dim very slightly so it seems the switch is functional turning the defroster on and off but I just can't get the bright "your rear defroster is on" indication to go off. Does this sound like a bad switch or a short somewhere else?

Thanks,

John

87 420SEL
00 C230K
00 A4 2.8Q
86 Masi Gran Criterium
Reply With Quote
  #2  
Old 07-02-2003, 03:39 AM
Senior Member
 
Join Date: Mar 2001
Location: Accokeek, MD
Posts: 683
Sounds like it has something to do with the switch itself... in relation to turning the bulb off and on. I'd open things up and have a look.
__________________
Earl



1993 190E 2.3
2000 Toyota 4x4 Tundra
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page