Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-02-2003, 10:01 PM
Registered User
 
Join Date: Dec 2000
Location: Fairfax County, Virginia
Posts: 856
Another OVP (Success) Story

I have finally resolved my loss of tachometer and A/C compressor function!

Initial loss of both functions at the same time started last year and usually a couple of whacks to the Klima relay would restore full function. The Klima on my 126 (91 350SDL) is located on passenger side next to and sharing a plastic socket block with the ASD module. Fastened to the side of it, but completely separate is a two 10A fuze OVP.

After tracing every darn wire and cleaning every connection (including relay pins and sockets) in the engine compartment over a period of two nights, I gave up and decided to put off taking the wiper motor transmission tray apart (necessary to get at the back of the socket block to check for poor connections/shorts) till the weekend. After a few emails from a couple of really great guys (Steve and Marshall) I decided to take a very careful look at the OVP (had previously checked the fuzes).

After reading comments by Beatle Juice, G-Benz, and Mick J plus an incredibly informative dialogue via email with Steve Brotherton and Marshall Booth, I removed the OVP and examined it ... looked OK on outside .... BUT, it appeared to RATTLE a bit ... hmmmm. Pried apart and found two brackets that hold points assemblies were no longer soldered to the board. Even more astounding, a very small spring that tensions one of the sets of points was rolling around inside .... voila!!!

Carefully reinstalled the spring, clamped the brackets to the board while I resoldered them back in place - resoldered everything else just for grins! Immediately got tach function back, but still had no A/C compressor. Swapped original Klima for the used I got and both now work 4.0!

This could have been a two failure problem, but I think I had likely damaged the original Klima as I resoldered it several times and, well, embarrassingly, probably beat on it a bit too much (only after receiving the new (used) one.

Thanks again to Steve, Marshall, Beatle Juice, G-Benz, and Mick J!

If only I could figure out why that ASD light stays on .... got a feeling it hydraulic issue, not electrical!
__________________
George Stephenson
1991 350 SDL (200K and she ain't bent, yet)
former 2002 E320 4Matic Wagon - good car
former 1985 300 CD - great car
former 1981 300 TD - good car
former 1972 280 SEL - not so good car
a couple of those diesel Rabbits ...40-45 mpg
Reply With Quote
  #2  
Old 07-11-2003, 05:02 PM
Registered User
 
Join Date: Dec 2000
Location: Fairfax County, Virginia
Posts: 856
Update on the ASD Light - after resetting it with OVP repaired, it has not come back on .... on the other hand, trhe triangle light does not illuminate during startup, either.

Tach and AC are working normally - can't tell if ASD is working, yet ... may pull dash to see if bulb is functional.
__________________
George Stephenson
1991 350 SDL (200K and she ain't bent, yet)
former 2002 E320 4Matic Wagon - good car
former 1985 300 CD - great car
former 1981 300 TD - good car
former 1972 280 SEL - not so good car
a couple of those diesel Rabbits ...40-45 mpg
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page