Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-04-2003, 09:45 PM
Kyle Blackmore's Avatar
Mostly Harmless
 
Join Date: Sep 2001
Location: almost beyond Hope...B.C.
Posts: 897
Question OVP relay resolder

I am trying to get the cover off the OVP without destroying it . I loosened around the top where the aluminium cover is crimped to the top and still there seems to be something holding it from coming apart . The problem I'm having is intermittent ABS light on and a surging of idle speed (usually together) and from what I've gathered researching here that is the culprit. The dealer wants $160Cdn for a new one and if all it takes is a few minutes with my soldering iron, it makes sense to try that first . I fixed my ACC amp in my 123 by resoldering it and saved myself about $400. Anyone get an OVP apart without destroying it please let me know the trick , thanks in advance .
__________________
1985 380SE- 160,000km 'Blistu' - Sold
1988 300CE- Eva,my garage mistress
2007 R350 4matic- The Black Pearl
2011 Ford Ranger-Work truck
1974 25' Trojan Sea Raider- 'Grannyknot'
2002 215 cm Atomic DH skis- Canadian SDH record holder, 175.5km/h- Vars 2010
Reply With Quote
  #2  
Old 07-05-2003, 12:30 AM
Kyle Blackmore's Avatar
Mostly Harmless
 
Join Date: Sep 2001
Location: almost beyond Hope...B.C.
Posts: 897
TTT

Anybody know?
__________________
1985 380SE- 160,000km 'Blistu' - Sold
1988 300CE- Eva,my garage mistress
2007 R350 4matic- The Black Pearl
2011 Ford Ranger-Work truck
1974 25' Trojan Sea Raider- 'Grannyknot'
2002 215 cm Atomic DH skis- Canadian SDH record holder, 175.5km/h- Vars 2010
Reply With Quote
  #3  
Old 07-05-2003, 03:40 AM
Registered User
 
Join Date: Jul 2001
Location: SoCal
Posts: 1,303
I bought a new one because I couldn't get the old one open, and didn't want to press the issue if the car might be undriveable as a result. After installing the new, I tried harder on the old cover, and it did finally come loose. A small amount of contact cement was responsible. Although I cleaned the relay contacts and resoldered the terminals, I keep the old one as a spare - I haven't tried it again.

Check on FastLane or other internet sources - they are much cheaper than the dealer.

Steve
__________________
'91 MB 190E 2.3
'08 RAV4 Ltd 3.5
'83 Lazy Daze m'home 5.7
Reply With Quote
  #4  
Old 07-05-2003, 04:26 AM
Registered User
 
Join Date: Apr 2002
Location: Surrey, Uk
Posts: 254
Have you taken the fuse out? that would hold it.
__________________
Mick J
'08 Chrysler 300CRD (MB OM 642 engine)
'95 E220 estate
'89 230TE (R.I.P.)
Reply With Quote
  #5  
Old 07-05-2003, 02:58 PM
Kyle Blackmore's Avatar
Mostly Harmless
 
Join Date: Sep 2001
Location: almost beyond Hope...B.C.
Posts: 897
Thanks Steve and Mick, the fuse was out ,but when it wouldn't come apart easily I put it back together and it worked fine for a while. Now it's acting up again and I don't want to spend anymore money on it , this car has become a moneypit lately so the more I can fix for free the better I'll feel.If all there is holding it is a bit of glue I'll just have to be a little more aggressive with it.
__________________
1985 380SE- 160,000km 'Blistu' - Sold
1988 300CE- Eva,my garage mistress
2007 R350 4matic- The Black Pearl
2011 Ford Ranger-Work truck
1974 25' Trojan Sea Raider- 'Grannyknot'
2002 215 cm Atomic DH skis- Canadian SDH record holder, 175.5km/h- Vars 2010
Reply With Quote
  #6  
Old 07-06-2003, 07:18 AM
Registered User
 
Join Date: Apr 2002
Location: Surrey, Uk
Posts: 254
If it's messing around you've nothing to loose even if you do break it!
__________________
Mick J
'08 Chrysler 300CRD (MB OM 642 engine)
'95 E220 estate
'89 230TE (R.I.P.)
Reply With Quote
  #7  
Old 07-07-2003, 02:31 AM
Kyle Blackmore's Avatar
Mostly Harmless
 
Join Date: Sep 2001
Location: almost beyond Hope...B.C.
Posts: 897
So far so good...

I finally got the case off , it was just the glue (?) around the edges . I found a 1" putty knife worked in between the case and plug base broke it free and it simply slid apart. I resoldered the board and cleaned it with some Radioshack Contact cleaner . Put it back together by lightly crimping it down , sealed it with a little RTV and plugged it in. The car started right up and no matter how many times I hit the OVP with a screwdriver I couldn't get the ABS light to come on .I also cleaned all the grounds under the hood that I could find . Now it's time to tackle the ACC push-button contoller.
__________________
1985 380SE- 160,000km 'Blistu' - Sold
1988 300CE- Eva,my garage mistress
2007 R350 4matic- The Black Pearl
2011 Ford Ranger-Work truck
1974 25' Trojan Sea Raider- 'Grannyknot'
2002 215 cm Atomic DH skis- Canadian SDH record holder, 175.5km/h- Vars 2010
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page