Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-07-2003, 06:55 PM
Registered User
Join Date: Jul 2003
Location: Miami Florida
Posts: 1

Helo! this is Robert and I am seeking you help on a problem with a 95 Benz S 320.

I puerchest this car from en old service friend the car was not cooling due to a leak in the evaporator. I replaced the eveporator with a new one. The new evaporator is a bigger the sales person told me that this was a modification made to this vehicle due to lack of cooling. The evap, TXV and Filter dryer were all looked up by the vehicle's vin number. All parts were properly installed and a proper vacumm and charge of 134 done. Now the ac cools fairly well at night and on over cast and cool days, but on not days the ac dose not cool well at all. on cool days the temp drops to about 60 deg. in the day hour it only dros to about 78 deg. at times the cluch sounds like it has dissengage but a visul shows that it it not dissengage. I send it to the Mercedes-Benz dealer and they were not able to fine the problem.

Can you help me with this situation?

Thank you.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:35 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page