Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-09-2003, 04:26 PM
Registered User
 
Join Date: May 2003
Location: NJ
Posts: 21
Unhappy Check Engine oil level !

Can anyone help?

This is the second times, first time was 2k miles ago and I add one quart 'mobil one'. I checked the garage floor and nothing is leaking. Should I take it to the shop to check? or just keep adding another 'Mobil One'

Thanks
__________________
00' CLK 430
Silver, K3, K4,Command
AMG Alum. Pedal
Momo "CF" Shift Knob
Lowenhart BR-5
Reply With Quote
  #2  
Old 07-09-2003, 04:37 PM
MTI's Avatar
MTI MTI is offline
Registered User
 
Join Date: Nov 2002
Location: Scottsdale, Arizona
Posts: 10,626
Abnormal oil consumption should always be checked. Lack of oil spots may not be the best test to rule out a leak, but would support a finding that the engine is burning oil internally.
Reply With Quote
  #3  
Old 07-09-2003, 05:33 PM
engatwork's Avatar
busy
 
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 11,775
You probably have a "cover" under the engine that keeps the oil from hitting the floor. If you can look on the engine side under the engine and there is an engine oil leak you may be able to see it laying in this cover. You will want to use a bright flashlight to look down in there.

With this new of a car I would suggest taking it back to the dealer and get their thoughts on it.
__________________
Jim
Reply With Quote
  #4  
Old 07-10-2003, 09:11 AM
Registered User
 
Join Date: May 2003
Location: NJ
Posts: 21
what kind of oil should I use?

Just wonder what kind of motor oil should I use? Cause the Engine Oil level is low and need to add 1.5 quart, so I stop by PEP Boy. I try to get 'Mobil 1' - 0w 40 which the Manual suggested, but they don't carry 0w40 and I end up use 15w50. Is it matter?

And also, anyone know how much did it cost for the dealer check up my car? My car already had 60K miles so the existing warranty won't cover it.

Thanks
__________________
00' CLK 430
Silver, K3, K4,Command
AMG Alum. Pedal
Momo "CF" Shift Knob
Lowenhart BR-5
Reply With Quote
  #5  
Old 07-10-2003, 09:15 AM
engatwork's Avatar
busy
 
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 11,775
You should be ok with 1-1/2 qt of the higher viscosity as long as it is Mobil 1.

Since your warranty is up I would strongly suggest finding a good independent shop. Look on recommended shops on this board in your area.
__________________
Jim
Reply With Quote
  #6  
Old 10-19-2003, 11:23 PM
Registered User
 
Join Date: May 2003
Location: NJ
Posts: 21
Unhappy Check Engine Oil Level Again

I got the Same message agin after +/- 2000 Miles drive. First is "Check Engine Oil Level" "1 Malfunction" while I still driving on the road, I pulled over and the second message w/ red screen pop up "Check Engine Oil Level - Visit Workshop" "2 Malfunction" .

I wait until I get home, stop the car, let it cool off a bit and check the oil level, the message said "Engine Oil Level - OK" I checked the dipstick and it is half way betwen Max and Min.

I start the car after half hour, everything is fine, no more malfunction.

What should I do? Take it to the shop? Anyone know what is the problem I have?

Thanks
__________________
00' CLK 430
Silver, K3, K4,Command
AMG Alum. Pedal
Momo "CF" Shift Knob
Lowenhart BR-5
Reply With Quote
  #7  
Old 10-19-2003, 11:48 PM
blackmercedes's Avatar
Just a guy
 
Join Date: Dec 2000
Location: St. Albert, Alberta, Canada
Posts: 3,492
Lucky you have the dipstick to verify the oil level. I don't understand what was so wrong with the old dipstick system, anyway.

You may have a sending unit going bad. That wouldn't account for the litre per 2000 miles consumption. Hey, that's not much, truth be told. I'd investigate the error message if it comes up again, and watch the consuption to see if it goes up over time.

And if you're going by the FSS oil change intervals, you might want to stop. Even with Mobil 1 you might want to buy some cheap insurance with more frequent changes.
__________________
John Shellenberg
1998 C230 "Black Betty" 240K

http://img31.exs.cx/img31/4050/tophat6.gif
Reply With Quote
  #8  
Old 12-27-2003, 11:51 AM
rivermasternc's Avatar
J. Scott Moncrief
 
Join Date: Feb 2003
Location: Burnsville, NC
Posts: 144
OIL SENSOR DEFECTIVE?

joiseygal:

You may be interested in the following thread. Apparently there were some issues with the early FSS oil sensors.

99' E320 oil level, ignition switch and Headrest cover

-Scott

EDIT:
Quote:
Just wonder what kind of motor oil should I use? Cause the Engine Oil level is low and need to add 1.5 quart, so I stop by PEP Boy. I try to get 'Mobil 1' - 0w 40 which the Manual suggested, but they don't carry 0w40 and I end up use 15w50. Is it matter?
Mobil-1 0W40 and 15W50 are readily available at WalMart and AutoZone in our area. FWIW.
__________________
https://goo.gl/photos/J8ZUVvAYiYqLxbD18

1989 560SL 111Kmi
2007 E550 4Matic 157 Kmi
2000 F250SD 7.3l, 1996 Explorer Ltd 5.0l
1965 VW Beetle Deluxe 115 Kmi
=========================
Previous MB:
1983 240D Euro Manual 144 Kmi
1983 300SD 495 Kmi
1986 190D 2.5 100 Kmi
1986 300SDL 202 Kmi
1991 300D 2.5 Turbo 91 Kmi
1998 E320S4 (4-matic wagon) 140 Kmi

Last edited by rivermasternc; 12-27-2003 at 03:51 PM.
Reply With Quote
  #9  
Old 12-27-2003, 02:20 PM
Registered User
 
Join Date: Aug 2001
Location: Evansville, Indiana
Posts: 8,150
Oil level at midway between the marks can sometimes cause the FSS to signal low oil on the highway.

At 60,000 miles I'd get the engine checked for leaks, as you shouldn't be using that much oil already, even though I'd not consider a quart in 2000 excessive yet. It does sounds as though this just started, though -- that indicates a leak to me.

One thing to look at is the oil filler gasket -- a leak here only shows up at highway speeds, and the oil won't be dripping anymore by the time you park the car.

Peter
__________________
1972 220D ?? miles
1988 300E 200,012
1987 300D Turbo killed 9/25/07, 275,000 miles
1985 Volvo 740 GLE Turobodiesel 218,000
1972 280 SE 4.5 165, 000 - It runs!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page