Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-09-2003, 05:12 PM
Registered User
Join Date: Sep 2000
Posts: 97
Glow Plug Relay Problem


I'm having some difficulties with the glow plug relay. I replaced it about 6 months ago, and now every so often, the relay does not come on and neither does the glow plug relay light in the dash.

The only way to fix this problem, seems to be do disconnect both electrical connectors from the timer and replace them back in 10 seconds

Now, the light will come on and everything is ok.

This only seems to happen intermittently?

Anyone seen anything like this before?
1) 84 300SD 285K+ Miles (Ver Calif)
2) 84 300SD 175K+ Miles (Ver Federal)
Reply With Quote
Old 07-09-2003, 08:32 PM
Registered User
Join Date: Aug 2001
Location: Evansville, Indiana
Posts: 8,150
New one to me. Makes me think you have current draw someplace you shouldn't, though, check for worn wires in the bundle. Sounds as if the relay "thinks" it's in operate mode when it's not.

1972 220D ?? miles
1988 300E 200,012
1987 300D Turbo killed 9/25/07, 275,000 miles
1985 Volvo 740 GLE Turobodiesel 218,000
1972 280 SE 4.5 165, 000 - It runs!
Reply With Quote
Old 07-17-2003, 05:35 PM
Registered User
Join Date: Sep 2000
Posts: 97

as an update I replaced the battery as it was bad and also replaced glow plug #5 behind the oil filter housing. I realized that I had previously changed plugs 1-4 to the newer BOSCH style adn that #5 was an older glow plug. Now all 5 are form the kit I bought from fastlane which came with the new relay.

No problems yet, so that may be the problem...either defective or mismatched glow plug
1) 84 300SD 285K+ Miles (Ver Calif)
2) 84 300SD 175K+ Miles (Ver Federal)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 02:58 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page