Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-09-2003, 08:05 PM
s500
Guest
 
Posts: n/a
I got A/C Finally! How come heat isn't coming out of central vents?

Hey everyone.. I just got and installed my blowermotor/regulator today and its working great. The cool air comes out of all 4 vents just fine but when I switch it to heat, it is only coming out of the side vents (not the central vents)...???

Does anyone know whats wrong?


Oh also the heating comes out of the front near the front window as well (for the antifog during rain/cold days)...
Reply With Quote
  #2  
Old 07-09-2003, 08:29 PM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 19,753
Check the manual. Those red and blue buttons on the center vent might have something to do with it. Meaning I read the manual but I don't remember what it said.

Sixto
95 S420
91 300SE
87 300SDL
83 300SD
Reply With Quote
  #3  
Old 07-09-2003, 08:30 PM
s500
Guest
 
Posts: n/a
Hehe. I tried every button but I'll look into it.

Thanks. I have to find my manual though.
Reply With Quote
  #4  
Old 07-09-2003, 09:17 PM
Registered User
 
Join Date: Aug 2001
Location: Evansville, Indiana
Posts: 8,150
Heat never comes out of the center vents, only cool air.

No floor air is a bad vac servo, can't tell you where it is, though.

Peter
__________________
1972 220D ?? miles
1988 300E 200,012
1987 300D Turbo killed 9/25/07, 275,000 miles
1985 Volvo 740 GLE Turobodiesel 218,000
1972 280 SE 4.5 165, 000 - It runs!
Reply With Quote
  #5  
Old 07-09-2003, 10:22 PM
s500
Guest
 
Posts: n/a
I am pretty sure heat should come out of central vents. I mean thats where the majority of the heat comes out of but for some reason it isn't when I try in my car...
Reply With Quote
  #6  
Old 07-09-2003, 11:11 PM
davidmash's Avatar
Supercalifragilisticexpia
 
Join Date: Mar 2002
Location: Arlington, TX
Posts: 11,731
I don't think so. I have had 4 MB and none of them have had heat in the central vents. That's the way they are built.
Reply With Quote
  #7  
Old 07-10-2003, 01:49 AM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 19,753
Quote:
Originally posted by psfred
Heat never comes out of the center vents, only cool air.
One of the things MB 'fixed' with the W140.

Sixto
95 S420
91 300SE
87 300SDL
83 300SD
Reply With Quote
  #8  
Old 07-10-2003, 01:54 AM
s500
Guest
 
Posts: n/a
Quote:
Originally posted by sixto
One of the things MB 'fixed' with the W140.

Sixto
95 S420
91 300SE
87 300SDL
83 300SD

haha.. I knew it. I was like what are they talking about. It was a while since I had heat running so I forgot but was 99% sure it used to blow very hot air during the cold times

Ill check the manual and see..thanks sixto.
Reply With Quote
  #9  
Old 09-13-2003, 01:52 PM
Snowman's Avatar
Registered User
 
Join Date: Feb 2002
Location: Chicago,IL
Posts: 230
Yeah I think you have to hit the red button for heat to come out and the blue button for cold to come out. It's weird I know.
__________________
1985 500SEL 124k miles
2001 Honda Civic EX
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page