Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-04-2000, 05:12 PM
Registered User
 
Join Date: Mar 2000
Location: Southampton, NJ
Posts: 126
When my 300D has been run a while the idle is rough and the car sits there shaking and after a long run on the highway it seems to do this more so. Any ideas??
I am wondering if the idle needs to be adjusted or what because when I bring the idle up 100-200 RPM the situation is not so bad. The situation happens when the idle is at 700-750.
BTW, I have recently changed the fuel filters and oil and these have not changed the problem.
Thank you for the help.

[This message has been edited by zachv (edited 04-04-2000).]
Reply With Quote
  #2  
Old 04-04-2000, 05:27 PM
Registered User
 
Join Date: Mar 2000
Location: Dallas, Texas
Posts: 218
Is this on a Turbo? I replaced and adjusted the rack bolt on my injector pump. It is the little bolt on the rear of the pump near the bottom. Several (thank you by the way) advisors on this forum told me to replace that bolt, and after adjusting several times, it has made a world of difference. I don't know if the non-turbo's used them, but I'm sure you'll get more very informed responses.
Also, if you haven't, run some Red-Line Diesel Catalyst through...you'll LOVE the results.
Robert


------------------
R Talley
84 300D-T
Reply With Quote
  #3  
Old 04-05-2000, 01:13 PM
Registered User
 
Join Date: Mar 2000
Location: Southampton, NJ
Posts: 126
What is the procedure to adjusting the "rack bolt" on the pump and how do you identify the bolt? And yes, it is a turbo.
Thanks for the reply.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough cold idle on 1991 420SEL BENZ-LGB Tech Help 15 06-20-2012 05:18 PM
rough or loping idle under strange conditions odie Diesel Discussion 0 01-20-2005 03:04 PM
E320 Rough Idle / Egr Problem earossi Tech Help 13 09-22-2003 10:14 AM
Sudden rough idle??? Something to check - 560SEL MikeTangas Tech Help 2 08-19-2002 12:10 AM
Sputtering and Rough Idle When Warm PThiringer Tech Help 2 05-28-2002 01:12 AM



All times are GMT -4. The time now is 05:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page