Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-18-2003, 10:51 PM
Registered User
 
Join Date: Sep 2002
Location: Puerto Rico
Posts: 103
Unhappy Burn smell from a/c vents E320 94, help!

I just came from the bakery and in the way it begun to smell like something is burning from the a/c vents, I stop the car and check under the hood but no, the smell does not come from the engine compartment. I start the car again and the smell began again when I put the a/c on, I put the a/c on high an more smell, I stop the car again wait a few minutes, when I start the car again smoke was coming from the a/c vents, after a few seconds the smoke stop. I put back the a/c on and it does not cold very well.
Can someone help me with this? Thanks in advance
Reply With Quote
  #2  
Old 07-19-2003, 08:52 AM
Registered User
 
Join Date: Sep 2002
Location: Puerto Rico
Posts: 103
Please if someone know, let me know, Thank you
Reply With Quote
  #3  
Old 07-19-2003, 11:45 AM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
I have seen a number of blower motors stink as they fail. Unfortunately the intake is in an area where it will also pull in oil burning from the exhaust so verify that first.

If it it is the motor, I have never seen it do anything except finally fail. Usually soon after the smell. The motor won't have anything to do with how cold the AC is only the volume. If it is not blowing strong it won't seem as cold.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #4  
Old 07-19-2003, 02:32 PM
Registered User
 
Join Date: Sep 2002
Location: Puerto Rico
Posts: 103
I think is a shorcut in the dash somewhere, because today I use the car in the morning with the a/c off and from the vents there was a heat coming out even with the a/c off. about minutes later smoke was coming out of the dash (center console, where the a/c controls are). If anyone know what is making the trouble, please help!!! Thanks in advance
Reply With Quote
  #5  
Old 07-19-2003, 03:57 PM
Registered User
 
Join Date: Sep 2002
Location: Puerto Rico
Posts: 103
I take out the climate control unit and have the board burn in a circuit, my question now is I have to check something else that cause this problem or just replace the climate control unit? Thanks in advance.
Reply With Quote
  #6  
Old 07-19-2003, 04:07 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Look for a shorted auxilary water pump.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #7  
Old 07-23-2003, 10:42 AM
Registered User
 
Join Date: Sep 2002
Location: Puerto Rico
Posts: 103
is this the one that goes under the washer fluid reservoir??
if I unplug this motor would affect my car operation??
Thanks in advance
Reply With Quote
  #8  
Old 07-23-2003, 11:34 PM
Registered User
 
Join Date: Sep 2002
Location: Puerto Rico
Posts: 103
Can someone tell me where is the aux motor???
Thank you
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page