Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-18-2003, 11:25 PM
Registered User
Join Date: Oct 2002
Location: South Carolina
Posts: 85
? Regarding Outside Temp Guage at Cluster

Just purchased an outside temp unit from ebay.
I did a search but could not find this question.
Here's goes-
The entire temp unit looks as if would simply slide
into the cluster from the front.
How is the unit attached behind the cluster?
Is there a clip of some sort or is it screwed in?
I tried pulling the cluster out today -
Is there really that much force needed to do this?
I could not get it to slide out. I may have been a little to cautious on the force I was using. Just felt that any more force would cause some damage.
Any assistance would be appreciated.
1993 190e 2.3
Spruce Green Metallic
62k original
Reply With Quote
Old 07-19-2003, 06:28 AM
Registered User
Join Date: Dec 2001
Location: Yorkshire England
Posts: 70
I did this to my wife's W124 a while back. It should be similar to your 190E.
Check out the archives under OTG, or use this:
Retro-fitting OTG to a W124 .



E200 Wagon 1994
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:55 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page