Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-20-2003, 02:14 AM
Registered User
Join Date: Jul 2003
Posts: 1

I have a 1999 SLK230 and on the tempeture controls knobs the
> illumination lamp went out on the left knob. I talked with a mechanic here
> in my area (Roanoke,Va.) and he says you have to replace the complete unit
> which is over $300.00 not counting labor. After checking with the parts
> department I found out they offer the bulbs but again the mechaninc say
> unit is sealed and you can't put them in?? The parts person also said the
> parts number had been changed about 4 times. I purchased a bulb and was
> going to atleast look at trying to install it. Any help you could give me
> for this problem would be very helpful..
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 02:44 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page