Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-20-2003, 06:25 AM
Registered User
Join Date: Jul 2003
Location: Brisbane
Posts: 1
Spitting Black smoke coming from exhaust system

Hello viewers from Australia.

I've just recently purchased a Mercede's 250se auto 1968 with 110 miles on the clock, from a friend who said the gear box had gone,it engages all gears but just no power.

The engines not running great at the moment,i've cleaned(not replaced)the plugs,cap & leads,the plugs we're black when i took them out turned the car over seems to run better but it's still missfiring & puffing out black smoke & spitting.
Could it be the electrics?
Should i buy new points/leads/plugs & cap & change oil & filter.
The engine has no power it runs in high rev's then warms up then stalls.
I don't think the gear box has gone i think the car needs a good tune up, please could somebody give me some good d.i.y tips on tuning this car up & getting it to run like the true classic it is.



Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:01 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page