Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-14-2000, 01:52 PM
Registered User
Join Date: Apr 2000
Posts: 16
I just got a 1979 240d w/170K. The glowplug light would come on only if I turn the key on and off several times. I just replaced the glowplugs but still the same. (no yellow light) Any suggestions?
Reply With Quote
Old 04-14-2000, 02:03 PM
Ron Zarantenello
Posts: n/a
I never had this problem with either of my D's, however it would be logical to check the ignition switch for a short (or loose wire) or the glow plug relay. My 380SL had a similar problem with the climate control. Sometimes I'd have to jiggle the ignition key to get things going.

Current: '86 420SEL, '81 380SL
Previous: '79 240D, '70 280SE, '81 300D.
Just about 600,000 miles on Mercedes products.
Reply With Quote
Old 04-14-2000, 02:19 PM
Registered User
Join Date: Apr 2000
Posts: 16
Where is the relay located on a 1979 240D. I know where it is on my 190D. But I'm lost on this one. Not much under the hood either.


Reply With Quote
Old 04-14-2000, 03:04 PM
Posts: n/a

In the first few years of the 123, 240D the relay was in several locations, but I believe that if you take out the instrument cluster, you will find it directly in front of the instrument cluster opening, mounted to the inside of the firewall.

Good luck,

Larry Bible
'84 Euro 240D, 516K miles
'88 300E 5 Speed
'81 300D Daughter's Car
Over 800,000 miles in
Mercedes automobiles
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Euro light differences, 500E vs 300E. JCE Tech Help 16 09-20-2004 06:00 PM
Replaced alternator, Battery Voltage at 12.0 volts, Red Battery Light on (83 240D) Carrameow Diesel Discussion 6 12-28-2003 07:11 PM
Replaced alternator, Battery Voltage at 12.0 volts, Red Battery Light on (83 240D) Carrameow Tech Help 5 09-21-2003 11:00 PM
PIAA Hype ke6dcj Performance Paddock 0 08-30-2001 06:06 PM
Fog Light installation in ML. blau Tech Help 5 02-12-2001 01:05 PM

All times are GMT -4. The time now is 09:15 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page