Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-13-2000, 10:10 PM
Alan
Guest
 
Posts: n/a
W126 500SEC ....All instruments except vacumn gauge are out..Is there a fuse somewhere I should check...Also ABS light is on..Thanks Alan
Reply With Quote
  #2  
Old 04-14-2000, 06:34 PM
Registered User
 
Join Date: Jan 2000
Location: New Bedford, MA USA
Posts: 1,583
Check the fuses, under the hood on the drivers side in the corner. I think #5 and #9 are for the instrument cluster, but check the diagram..

------------------
Jeff L
1987 300e
1989 300e
1987 BMW 325
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Who Rebuilds or Tests Instrument Clusters? Ed Hanna Tech Help 32 07-22-2008 04:06 PM
Instrument panel bulb failure jjrodger SL Forum 8 01-12-2004 01:56 AM
removal of instrument cluster cover on dash PAUL GIVENS Tech Help 3 08-05-2003 02:12 PM
newbie conquers tailgate struts and dash lights! details...(long but helpful?) shawnster Diesel Discussion 0 05-19-2002 05:15 PM
Dash instrument cluster CMuc Tech Help 8 04-17-2000 12:22 AM



All times are GMT -4. The time now is 12:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page