Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-26-2003, 12:57 PM
Registered User
Join Date: Jul 2003
Posts: 20
Angry mass airflow p0101 fault / she's mad/attention required

My wife's 96 C220 has its check engine lite on. The performance differs from normal in two regards. First, the engine surges to 1200 rpm two to three times when starting. Secondly, the car occasionally stalls at a stop. A db2 tester demonstrates a fault code of p0101. This code indicated a hot film mass air sensor "circuit malfunction". I have wiggled around the plug wire on the premise that the wire harness can be the problem.
I have disconnected the plug from the air sensor. I believe that the car ran better. I questioned this since I would have expected the opposite. How can I be certain that this problem requires the replacement of this expensive sensor. Can a volt /ohm meter help show a weakness ? If a part is required, like the air mass sensor, the part 000-094-00-48 does not appear to be available with the vendor of this excellent service.

Last edited by tryfunke; 07-27-2003 at 08:37 AM.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:12 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page