Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-02-2003, 05:50 PM
Registered User
Join Date: Aug 2003
Location: District of Columbia
Posts: 6
Question [b]Harsh downshift & upshift[/b]

After dealer service at 60K-- E320 Wagon(1995) exhibited harsh downshift at slow speed and harsh upshift into 3rd gear at 40 mph or so.

Dealer examined and adjusted throttle cable and trans cable, but problem remains unfixed. Dealer discovered bad kick-down solenoid, which I will replace, but would like to know what's the next course of action to bring trans back to normal?

Your kind help is welcome.

1995, E320 Wagon, Emerald Green, 68k
Reply With Quote
Old 08-02-2003, 07:50 PM
Registered User
Join Date: Aug 2001
Location: Evansville, Indiana
Posts: 8,150
Vacuum line from the manifold (or vacuum amplifer) to the transmission is damaged or the modulator is bad.

1972 220D ?? miles
1988 300E 200,012
1987 300D Turbo killed 9/25/07, 275,000 miles
1985 Volvo 740 GLE Turobodiesel 218,000
1972 280 SE 4.5 165, 000 - It runs!
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:57 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page