Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-05-2003, 09:27 PM
Registered User
Join Date: Mar 2003
Location: Houston, Texas USA
Posts: 59
Air Conditioner 1984 300 SD

I have a very strange air conditioner. Some days it cools my car very well and I am too cold; the next day, it won't cool well and I will be too hot. This has no relation to the outside weather. It can be 100 degrees outside, and 60 degrees inside my car, or 85 degrees outside, and 82 degrees inside my car, with the ac on. Any ideas?
Jacob Wissler Jr., Houston, Texas, 1984 300 SD
Reply With Quote
Old 08-06-2003, 07:16 AM
Posts: n/a
I would start by checking the hose that directs air across the temp sensor. I know exactly where this hose is on other models but I'm not familiar with the 126 cars. Hopefully a 126 person will chime in and offer more details.

If the foam hose is gone, which is likely because the disintegrate over time, you are not getting a good air sample across the sensor which will cause eratic Climate Control operation.

Good luck,
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:13 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page