Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-09-2003, 09:33 PM
Registered User
Join Date: May 2002
Location: Hayward, CA
Posts: 45
1987 260E rear windows don't work

Neither of the rear windows on my 260E go up or down. I checked the fuse; furthermore both fronts do work. I can hear a sound (a fant relay sound) comming from either rear door when I push that window control switch. Can anyone tell me if perhaps both motors may be bad or where I should be looking for the problem? Thanks in advance.
Reply With Quote
Old 08-10-2003, 08:20 AM
J.HIDALGO's Avatar
Registered User
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
The window fuses are connected in an X pattern.

In other words, right front, left rear and left front, right rear, that rules out the the fuses. Since you hear something when you push the switch, the motor is probably working and so is the switch.
You can try to close the door with the switch push in and see if that makes the window work but, the only way to find out for sure is to remove the door skin and look.
Good luck!
'86 300E
Reply With Quote
Old 08-10-2003, 10:30 AM
Registered User
Join Date: May 2002
Location: Hayward, CA
Posts: 45
Is there any way the child safety switch if broken, could affect the counsel mounted rear window switches? Oh by the way, while my 123 cars are a snap to remove the door panels, this thing is giving me fits. I've removed the trim at the latch point (rear of door). I've removed the switch mount plastic part and the 6mm bolt at top of grab handle. I assume the panel needs to be lifted up. Does the inside latch control need to be removed, if so, How? What am I missing? Thanks again
Reply With Quote
Old 08-10-2003, 04:27 PM
Registered User
Join Date: Apr 2002
Location: Surrey, Uk
Posts: 254
The procedure to remove the door panel is described at door panel removal help??? 300E 2.6
Mick J
'08 Chrysler 300CRD (MB OM 642 engine)
'95 E220 estate
'89 230TE (R.I.P.)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:16 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page