Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-10-2003, 01:39 PM
Registered User
Join Date: Aug 2003
Location: vancouver canada
Posts: 2
transmission problem

1967 230 sl auto trans will not stay inhigh gear jumps in to neutral ican drive the car in 3 gear the rest of the transmission works fine any idias?
Reply With Quote
Old 08-10-2003, 02:16 PM
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Sounds like a defective clutch pack.
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
Old 08-10-2003, 03:55 PM
Registered User
Join Date: Mar 2002
Location: Mandeville, LA
Posts: 13
I've also seen this happen due to a bad pilot bearing ( that receives the transmission input shaft) in the clutch.
'97 E300 Diesel (60k)
'99 Chrysler T&C
'87 300D Turbodiesel (sold)
'81 300SD Turbodiesel (sold)
'77 240D (sold)
'73 280 SE 4.5 (sold)
'66 250 S (sold)
'66 230 (sold)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 03:16 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page