Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-11-2003, 11:33 PM
Registered User
 
Join Date: Oct 2001
Location: nebraska
Posts: 1
Two problems with my 1975 280c

hello,

The first problem is battery electrolyte all over that side of the engine compartment. Could this be overcharging? MB put the catylitic convertor under the hood just inches from the battery. Could it be just too hot?

The second problem is the car will not restart if its been running for more than may be fifteen minutes. And it won't restart for HOURS. Best to let it sit overnight. If it's cold, the car starts right up! The engine will crank just great, but no hint of a start. And it will run on the highway for hours, but come to a stoplight and it wants to stall. Could this be a bad coil? It sits near that catylitic convertor too.

Thank you--pj
__________________
pjpear
1975 280c benz
1954 mercury custom
1985 custom cruiser
1986 caprice wagon
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page