Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-28-2000, 10:20 PM
Registered User
Join Date: Apr 2000
Location: eastern NC
Posts: 149
My tach works briefly and then just quits. Sometimes it works as soon as I start up but other times not at all. Never lasts very long. Any thoughts? Thanks.

1985 380 SE 194K
Reply With Quote
Old 04-29-2000, 10:29 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Most of the time on the gas cars, you will have to replace the tach to repair. Make sure that all of the connections are on good and tight.

Donnie Drummonds
1992 500E (very soon I hope
1981 280GE SWB
Reply With Quote
Old 04-30-2000, 11:19 AM
Registered User
Join Date: Apr 2000
Location: eastern NC
Posts: 149
Thanks, Benzmac. I was afraid of that. I was nervous about pulling the instrument cluster. I have the service cd and have seen the part on removal but it doesn't look that easy to me. IS this a DIY?
Reply With Quote
Old 04-30-2000, 12:37 PM
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Pulling the cluster on a 126 chassis is one of the easier models.

If you decide to do this, you might take it a step further. We find that almost all tach failures are either bad solder connections or bad capacitors (available at radio shack). Just replace them all. If you are planning to chuck it you might as well give it a try.

Steve Brotherton
Owner 24 bay BSC
Bosch Master, ASE master L1
26 years MB technician
Reply With Quote
Old 04-30-2000, 05:45 PM
Registered User
Join Date: Apr 2000
Location: eastern NC
Posts: 149
Thanks Steve, maybe I will try it after all.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tach fixed, A/T shifting changes (91 190e 2.6) tjh Tech Help 0 10-31-2004 10:21 PM
ECU and Tach on 85 300TD benzzy Diesel Discussion 5 09-24-2004 11:34 AM
Adding a tach to a 300TD 81Wagon Diesel Discussion 8 01-11-2004 07:05 PM
Tach making AGGRAVATING noise! rwthomas1 Diesel Discussion 3 12-29-2003 09:59 PM
Tach not working- not tach amp rs828 Diesel Discussion 3 12-23-2002 10:05 PM

All times are GMT -4. The time now is 06:46 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page