Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-22-2003, 01:13 PM
Registered User
Join Date: Oct 2001
Location: Atlanta Ga
Posts: 281
Angry ALL of my lights work! WHY does dash say otherwise!?

This has only been annoying me for a couple of days but is there a way to either reset this thing or what should I look for as far as possible causes for my dash's "light out" coming on although all of my lights are on. I've found myself pulling over and looking at all of my lights (I even back up and face a building that I can see the reflection on their windows to make sure all of my brake lights,etc are working and in order. Any suggestions because this is driving me nuts! I did however notice a bulb out in my rear lower door (but that's been out since forever-and I have the bulb but haven't replaced it yet- I just thought,boy is THAT trifling!)

Any help is appreciated

1997 E320
1986 560SEL
1983 300SD
1972 220D
1970 250C SOLD
1971 250C SOLD
Reply With Quote
Old 08-22-2003, 01:37 PM
Registered User
Join Date: Aug 2002
Location: La Quinta, CA
Posts: 271

Be sure to check both of the small lights for the rear license plate. Even if one of the bulbs is burned out there will be illumination on the stand on your head and look underneath where the bulbs are and make sure both bulbs are lit. I had this problem with my 560 SEL.
Reply With Quote
Old 08-22-2003, 01:49 PM
G-Benz's Avatar
Razorback Soccer Dad
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
Have you figured out what scenario causes the indicator to light up? Is it on all of the time, or just when you tap the brakes for instance? Of does it come on, but turn off when you switch on the headlights (or vice versa)?

Your courtesy lights are not part of the system, just the exterior lights. And as DJNEWK2 stated, the license plate bulbs are commonly overlooked.

Also, a bulb on its way out will set off the dash light, even though it still appears to work. Look for any bulbs (especially in the taillight housing) that appear discolored. The system works on resistance, so a filament on its way to burning out will give off a different resistance, and possibly set off the light.

Note that when replacing bulbs, the wattage and housing is very important. For the taillights, the correct bulb wattage is embossed near each respective socket. Use Philips, Osram, or Sylvania, with the nickel-plated housings, not the domestic cadmium-plated ones...
2009 ML350 (84K) - Family vehicle
2001 CLK430 Cabriolet (71K) - Wife's car
2005 BMW 645CI (124K) - My daily driver
2012 Mustang V6 (60K) - Daughter's car
Reply With Quote
Old 08-22-2003, 02:03 PM
Registered User
Join Date: Jan 2000
Location: New Bedford, MA USA
Posts: 1,583
If it's the 86, check the third brake light(inside the rear window). A lot of folks tend to overlook that one.
Jeff Lawrence
1989 300e
2000 Dodge Grand Caravan SE
No matter what you fix, there will always be something else to fix..
"Warranty" is just another way of postponing the inevitable.
Reply With Quote
Old 08-22-2003, 05:06 PM
Gilly's Avatar
Registered User
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
License lights and third brakelight are good ones, also the small rear "side" marker lights in back (around the side of the tail light lenses.

Reply With Quote
Old 08-22-2003, 06:29 PM
Posts: n/a
Don't forget the rear fog light if your car has one.
Reply With Quote
Old 08-22-2003, 08:08 PM
Registered User
Join Date: Aug 2001
Location: Evansville, Indiana
Posts: 8,150
Replace all bulbs in pairs with Osram (my preference) or other OEM bulbs. If you replace just one of a pair and the current draw is different that the one you left if, the lamp goes on.

The Benz isn't as bad and the Volvo -- took three tries to get a pair of brake lamp bulbs that wouldn't set the silly thing off. That's why I buy Osram -- they were the only ones to work.

1972 220D ?? miles
1988 300E 200,012
1987 300D Turbo killed 9/25/07, 275,000 miles
1985 Volvo 740 GLE Turobodiesel 218,000
1972 280 SE 4.5 165, 000 - It runs!
Reply With Quote
Old 08-22-2003, 09:00 PM
dakota's Avatar
Moof !
Join Date: Jul 2000
Location: Seattle WA USA
Posts: 469
Does the light monitor come on when you first turn the lights on? If it does, you know it's not the brake lights. If it comes on after the first time you press the brakes, then it's probably a brake light. You may further eliminate lights by using the blinker to isolate. (Remember to trun off ignition each time to reset.)

If you are positive that all lights illuminate (including 3rd brake, license (2) lights), it is probably a light that is barely intermittent, or a socket that is slightly corroded. Clean all the sockets, including the contact posts and the ground housing. You will find the culprit.
1992 300CE Sportline Sophie
1990 300E Emma - in the family
1979 240D Josephine - sold, but not forgotten
2004 Pacifica AWD
Reply With Quote
Old 08-27-2003, 02:10 PM
Registered User
Join Date: Oct 2001
Location: Atlanta Ga
Posts: 281
Thanks...I actually got it and it was some corrosion on my signal bulb.Just sanded down and greased it (along with all others) and all is well.
1997 E320
1986 560SEL
1983 300SD
1972 220D
1970 250C SOLD
1971 250C SOLD
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:44 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page