Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-23-2003, 09:21 PM
Registered User
Join Date: Sep 2001
Location: Maryland
Posts: 6
w140 a/c blower speed

I have a 94 S350, A/C blows nice and cold, but the blower fan speed stops increasing after "auto" position. It used to continually increase.

Is it a problem in the a/c push button unit or a relay or motor ?

Any help would be appreciated.
94 S350
93 300SD / 500SD
Reply With Quote
Old 08-23-2003, 10:02 PM
Registered User
Join Date: Aug 2002
Location: gold hill ,n.c.
Posts: 44
140 a/c speed

hope someone answers this post because i have the exact same problem with my '95 s350
luke morgan '84 300dt 180k,'85 300dt 220k, '95 S350 117k
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:21 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page