Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-26-2003, 10:13 AM
Registered User
Join Date: Feb 2001
Posts: 84
Light Control Relay in 300CE

My idiot light in the dashboard came on and realized that the rear side marker light on the passenger side was out.
Upon further investigation, realized that there was no power coming to it. So, I did find the circuit, checked for shorts, continuity etc, all checked out OK.
I then removed the light control relay and then I open the relay cover, and I found the thin metal strip was burnt, so T resoldered
the bridge that was burnt.
Now, I get power to that dead circuit, but my idiot light stays on with all the circuits were OK.
I guess there must be some resistor that may be bad.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:32 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page