Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-28-2003, 04:12 PM
Registered User
Join Date: Mar 2003
Location: Maryland
Posts: 23
Question 2 DIY questions

I have 2 questions for you experts out there...

1) Is replacing the motor mounts on a '97 C230 (75K mi, W202) a DIYer? Is there anything I should know before I do it like undoing the shift knob? I believe I have narrowed it down to the mounts; grinding noise when going around corners, suspension squeak on bumps, sometimes (when it rains) a rattle behind trans at idle.

2) How do you remove the cover to the in-car temp sensor? The buzzing is annoying...thought it was a short until I did a search for question #1.

Thanks in advance,
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:20 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page