Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-02-2003, 12:39 PM
Registered User
Join Date: May 2001
Posts: 128
98 C230 AC blows hot and cold

I purchased a 98 C230 normally aspirated last December. We turn on the AC by pressing the Auto button on the climate control and adjusting the temps down. The fan speed automatically gets faster. It blows nice and cold. Park the car. Come back 4 hours later. Do the same thing and it won't blow cold air.
Reply With Quote
Old 09-02-2003, 10:02 PM
Live to Learn
Join Date: Mar 2002
Location: Raleigh NC
Posts: 145
Could be the evaporator temperature sensor.

Mercedes Benz Master Tech
ASE Master Technician
Diagnostic Technician
Owner of "Behind the Star Inc."
Raleigh NC.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:07 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page