Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-03-2003, 02:43 PM
Registered User
 
Join Date: May 2003
Location: DC Metro Area
Posts: 365
ABS Light on & Cruise Control Inop.

My 1995 E420 has just developed the following problem:

When i turn the car on, and then put it in drive, after traveling about 2 inches the ABS light illuminates. Additionally, the Cruise Control does not work either. Strangely, when I put the car in reverse the ABS light does not come on, but as soon as I put it in Drive the light illuminates.

I have read about the possibility of the stop light switch causing this problem. I've checked and the rear brake lights are working.

Any suggestions on what to do? Hopefully I can fix this problem without spending a fortune. My A/C evaporator is dead - and my wife may make me sleep outside if I have to spend more to fix my car in addition to the couple Thousand $ the evap. will cost me.

Thanks,
Troy
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page