Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-08-2003, 01:32 PM
Registered User
Join Date: Sep 2003
Location: Northern Va.
Posts: 66
96-S320 front-end noise

I have a 96-S320 W/60K miles. I'am getting a noise from the left front which sounds like a heavy treaded tire on dry pike when I make a left turn ONLY. It is speed sensitive and increases in intensity as you increase/tighten up the turn. I replaced the wheel bearing, but its still there. Cleaned and checked other bearings, no-go. Any other Ideas of things to look for?? Thanks for any input, I'am a typical backyard mechanic, do all the repairs not requiring special tools or knowledge... Ron
Reply With Quote
Old 09-08-2003, 03:53 PM
DR.DIESEL's Avatar
Senior Member
Join Date: Mar 2003
Location: Puget Sound, Washington St.
Posts: 522
What size tires are you runnin? Are any of the plastic fenderwell
liners pushed out and rubbin on the tires? Look for rub marks on
the inner fenders and splash panels. Fairly common problem.
The OE tire size is 225/60/vr16
Good luck.
Reply With Quote
Old 09-08-2003, 04:08 PM
Registered User
Join Date: Sep 2003
Location: Northern Va.
Posts: 66
96 S-320

I've looked for all those type things, everything all around the tire look normal, ie. no worn spots, rubbing, etc. I'am using the std. size tire also. Thanks for your response. I also have another question re-the S-320 for anyone, does this car have a charcole filter for the cabin area, and if so, how do you get to it??thanks

Last edited by RConrad; 09-08-2003 at 04:18 PM.
Reply With Quote
Old 09-09-2003, 04:54 AM
Registered User
Join Date: Oct 2002
Posts: 188
Charcole filter depends if you have the switch. The switch is properly the only easiest thing to check. Do you have the switch that turn on/off the charcole filter?? In the early 140, the hood will have series of opening near the windshield.... however in the later model, all have the opening so its not the best bet.

If you still unsure to the switch, you can go into diag. mode for the A/C module and look up from there. Which A/C module do you have?? Do you have the 3 seperate panel module or the one big LCD module. Both have been described on this board as to how to go into the diag. mode.

If you have charcole filter, your car will have 3 filters. Re-circ filter, pre-filter and the charcole filter. The Re-circ filter can be changed in 10 minutes and is inside the car under passenger dash.

The pre-filter is just before the blower which can be changed in 20 minutes. U need to open the hood, remove the BIG black thing going across left and right and u will see the pre-filter. Don't force anything, there are a few electrical and vacum connections.

the charcole..... u must remove the wiper, wiper motor and others to access it.... its costly too... not a recommended frequent item. Its also described on this board as to exactly how to do it.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:31 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page