Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-10-2003, 08:58 PM
Registered User
Join Date: Sep 2003
Posts: 1
190e fuel delivery problem

Help! My 1985 gas engined non-16v 190e quit. I drove it home and parked it in the garage, the next day it started and quit. It cranks over fine. I have spark. I have compression. I have cracked a fuel line connection at the fuel distributor and there is gas. I do not know how much pressure as I don't have a gauge. If I pour gas in the intake it will run for about 5 seconds until the gas is cleared out and dies. Any ideas?
Reply With Quote
Old 09-11-2003, 08:43 AM
Jim's500E's Avatar
Large Member
Join Date: Mar 2001
Location: Manchester, Connecticut
Posts: 1,325
Clogged fuel injector(s) or fuel filter maybe?

1992 500E
2007 CLK63
2003 Audi RS6
2001 Audi allroad
Reply With Quote
Old 09-11-2003, 04:12 PM
Registered User
Join Date: Jul 2001
Location: SoCal
Posts: 1,303
You need greater than 40+ psi at the injectors for them to open. I would suspect low pressure - bad regulator or fuel pump.

'91 MB 190E 2.3
'08 RAV4 Ltd 3.5
'83 Lazy Daze m'home 5.7
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:56 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page