Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-15-2003, 03:49 AM
Don O'Hagan
Posts: n/a
Question 1972 350SL surges

1972 350SL starts up cold revs up to about 2000 for a couple of min. then surges up / down for a few min. then idles at about 1000 takes off then misses bad during accelaration then runs good at higher speed when at a stop sign misses while in gear and brake on when hot starts up good idles at about 1000 and misses during accelaration has new points plugs cond cap wires rotor Thanks for any HELP

Last edited by Don O'Hagan; 09-15-2003 at 04:10 AM.
Reply With Quote
Old 09-15-2003, 04:36 AM
Registered User
Join Date: Jul 2003
Posts: 78
Check for oil on EFI trigger points in distributor for the missing problem. There are four of them inside clear plastic covers that you have to remove if you clean them. Each fires a pair of injectors :1&5, 4&8, 3&6, 2&7, so if missing is due to bad points, it will occur on one of these pairs.

Surging during warm-up is likely due either to improper idle speed adjustment (should be about 500-550 when in gear at normal temp) or malfunctioning auxiliary air valve. Refer to this thread:

My 72 350sl still has a problem with it's idle.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 01:13 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page