Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-17-2003, 03:29 PM
Registered User
Join Date: Sep 2003
Location: Cambridge MA
Posts: 63
"Restore" oil additive

I recently purchased an 89 300CE. I'm very happy, for 7k mi, car has been perfect, and beautiful. My only nightmares come after reading horror stories on this site! Maybe I've got a good one.

PO put in a can of "Restore" with each oil/filter change. I have done the same (twice). He said it was done preventitively. Car has 160K and burns no oil, none. (Leaks less than 1/2 quart per 3K change interval) I am considering changing to synthetic oil. Should I quit on the "Restore"? Maybe I should just leave well enough alone and continue on my present regimen.

Any comments?
Reply With Quote
Old 09-17-2003, 03:58 PM
Registered User
Join Date: Mar 2003
Location: Southern California
Posts: 2,011
Virtually every OE I know of specifically recommend to NOT USE any supplemental engine oil additives. A proper additive package is included with all modern API certified oils.

The best advice for motor oil - API service category and viscosity is in your owners manual.

Reply With Quote
Old 09-17-2003, 05:34 PM
Registered User
Join Date: Nov 2000
Location: Vernon, CT
Posts: 1,845
I would definetly stay away from anything that is supposed to fill in the fine scratches in the cylinder walls. Simply because that same material could plug your oil filter. Religous oil changes, with good oil will be all you need to do. BTW MB allowance for burning oil is as high as 1 quart every 600 miles.
1994 MB E320 Coupe (199,500 mi)
1992 MB 190E 2.6 (173,000 mi)
1983 Porsche 911SC (148,000 mi)
2004 Volvo V70 2.5T (198,000 mi)
PCA member
MBCA member
President of CT/Westchester Section
Reply With Quote
Old 09-17-2003, 05:47 PM
KNanthrup's Avatar
Registered User
Join Date: Mar 2002
Location: Issaquah, WA
Posts: 180
Originally posted by rickjordan
BTW MB allowance for burning oil is as high as 1 quart every 600 miles.
Really? Wow, that is interesting. Well, I thought mine was getting bad going it every 1500 miles or so, but I guess I might be fine for a little while... then again I don't see any blue smoke or any smoke for that matter.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:59 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page