Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-25-2003, 01:23 AM
Registered User
 
Join Date: Apr 2003
Location: Merced, CA
Posts: 95
Cool Auxiliary fan problem solved

If you're having a problem with your auxiliary fan, you might want to check out the fuse.

All summer long, I've had a probem with the fan in my 84 380SE. Been reading all of the information in this forum about the fan, and I guessed I was facing a bill of several hundred dollars. So I put the fan problem on hold and suffered. When the temp gauge hit 100, the air conditioner went off and the windows came down. And I suffered.

Well ... yesterday, I followed the advice of somebody in this forum and pulled the fuses and sprayed them with electrical contact cleaner. I figured some had gotten a little corroded over the past 19 years.

Got to the last fuse, and lo and behold, it was broken. I checked the diagram, and guess what. It was the fuse for the auxiliary fan.

Replaced the fuse, and the auxiliary fan problem is solved.

Moral: If you're having problems with the fan, check the easy things first ... things like the fuse.

I hope this works for at least some of you.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page