Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-26-2003, 01:16 AM
afmcorp's Avatar
Registered User
 
Join Date: Jan 2002
Location: NW Indiana LaPorte
Posts: 571
87 420 no center vents on all positions

just a quick ? on analysis.

my 87 420sel does not send air thru the center vents on any setting of the climate control switches.

would this mean more than one or all the actuators could be bad or just the main vaccuum line to the climate control?

and 1 last ?. i've read several post describe a green vacuum line thru the dash causing problems....but the only vac line i can see is the one from the engine manifold. i've looked 3-4 times and i can not see a green vac line. i do see some vac line on the right side back behind the battery but they are not green. what am i doing wrong?

tks
craig
__________________
Thanks Much!
Craig

1972 350sl Red/Blk 117k
1988 420sel charcoal/Blk 140k
1987 420sel gold/tan 128k
See My Cars at:http://mysite.verizon.net/res0aytj/index.html

Pound it to fit then Paint it to match!

There is only First Place and Varying degrees of last!

Old age and deceit will overcome Youth and Enthusiasm every time!

Putting the square peg in the round hole is not hard... IF you do it fast enough!

Old enough to know better but stupid enough to do it anyway!
Reply With Quote
  #2  
Old 09-26-2003, 02:31 AM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 19,751
No air from the center vents on max cool (thumbwheel on min, button with black up arrow and white down arrow selected) could mean no source vacuum or a problem with the diverter actuator. I think you'd get some air from the center vents if there was no source vacuum because the center actuator would be at rest with the center vent flap open. That would allow some backflow to the center vents. Do the defrost vents close when it's on max cool? If so, you have source vacuum.

The center actuator of my SD is bad so I get heat through the center vent. Take that, MB The compressor is long gone so there's no AC.

I don't know about any green line. Sounds like something you'll find in Boston.

Sixto
95 S420
91 300SE
87 300SDL
83 300SD
Reply With Quote
  #3  
Old 09-26-2003, 03:32 PM
afmcorp's Avatar
Registered User
 
Join Date: Jan 2002
Location: NW Indiana LaPorte
Posts: 571
center vent air

tks for your response.

i may have over stated no air. there is only enough to feel it. there is no projection of air only the slightest faint of air. 3 inch from the vent you wouldn't know it had any air.

there is one actuator that appears to work. i removed the glove box so i can see the one on the right. with the car on when you actuate it, it does move but no center air. i've held it in place and no center air.

this is all i can say because that is it as far as my probing has gone.

tks much
craig
__________________
Thanks Much!
Craig

1972 350sl Red/Blk 117k
1988 420sel charcoal/Blk 140k
1987 420sel gold/tan 128k
See My Cars at:http://mysite.verizon.net/res0aytj/index.html

Pound it to fit then Paint it to match!

There is only First Place and Varying degrees of last!

Old age and deceit will overcome Youth and Enthusiasm every time!

Putting the square peg in the round hole is not hard... IF you do it fast enough!

Old enough to know better but stupid enough to do it anyway!
Reply With Quote
  #4  
Old 09-26-2003, 03:50 PM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 19,751
Through the glove box opening you'll see tandem actuators for the recirc flaps. Stick your hand in to the left and up and you'll feel the defrost actuator. You have to remove the ACC control panel to get to the center vent and footwell actuators. I've never seen the diverter actuator but I believe it's inboard of the accelerator pedal.

Sixto
95 S420
91 300SE
87 300SDL
83 300SD
Reply With Quote
  #5  
Old 09-26-2003, 09:10 PM
Registered User
 
Join Date: Aug 2001
Location: Evansville, Indiana
Posts: 8,150
I don't believe the AC line in the W126 is green for some reason. Grey and red?

Whatever.

It will have a check valve, so you can just hook the ol mitivac to all the lines going to the passenger compartment and draw a vac. One will be the vac "economy" gauge on the dash if you have one.

If you get a system that moves the flaps as you push the buttons but leaks down, you have some bad diaphrams or swtichover valves (they don't usually fail, but it's not impossible). If it works fine with the MitiVac, you have a bad hose going to the manifold.

Peter
__________________
1972 220D ?? miles
1988 300E 200,012
1987 300D Turbo killed 9/25/07, 275,000 miles
1985 Volvo 740 GLE Turobodiesel 218,000
1972 280 SE 4.5 165, 000 - It runs!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page