Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-27-2003, 03:14 AM
Newbie Benz Driver
 
Join Date: Dec 2002
Location: Between Oakland and Vallejo, CA
Posts: 253
380SL no start

I have a 1984 380SL, and when i replaced the fuel frequency valve, the car ran richly, i turned the mixture screw to get it at 70%, and then turned it to get 50%, until the engine died at 58%. Now it won't start at all, the plugs were soaked with fuel, i a few hours later, the engine would catch for a second and die, then will crank, but won't start. I also replaced the water pump, could ignition timing have anything to do with this?
__________________
1984 380SL-driving and service privileges.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page