Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-28-2003, 01:40 AM
Registered User
Join Date: Sep 2003
Location: Washington State
Posts: 8
Unhappy '89 560SL Electrical Problems-Need Help

I just bought a 1989 560sl and am hoping that someone can help me with a few electrial problems:

I found the wire which connects to the heated window washer nozzles has been cut. Would this effect anything else?

My drivers side inside courtesy light also does not work(I replaced the bulb and still not working)

Also my anti-theft factory alarm does not work (Replaced both fuses in auxillary fuse box and checked all fuses in main fuse box.)

Oh...and my gauge that shows outside temperture is not working. (goes all the way to end as soon as ignition key is turned, returns to zero when key is off)

Could any of these problems be related?
Would appreciate any help on these issues.

1989 560SL
Reply With Quote
Old 09-29-2003, 01:27 AM
Registered User
Join Date: Sep 2003
Location: Washington State
Posts: 8

Doesn't anyone have any suggestions on the above???
Reply With Quote
Old 09-29-2003, 11:30 AM
Registered User
Join Date: Sep 2002
Location: Newcastle upon Tyne, UK
Posts: 215
There have been some models where the heated jets have malfunctioned and overheated. I guess cutting the wire is the cheapest way of solving the problem.

Check the operation of the door switch for your courtesy light.

I'd be surprised if a 14 year old alarm system was still working. Ditch it and get a modern one fitted.

Either the outside temp sensor has failed, or the wiring to it has failed.

All these problems are related, but only to the age of the car and the fact that fixing minor problems like this adds to the cost of ownership without making the car any more driveable or reliable.
Cheers, Neil
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 07:37 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page