Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-29-2003, 04:40 PM
Registered User
 
Join Date: Sep 2003
Posts: 1
300cd-no crank

Plse bear with me..I'm new to Mercedes ownership-have inherited a 1985; 300cd -Problem: key on, steering col. lock frees up, all appropriate lights on, incl glow-plugs.. bat cond good ( load tests at 750CCA, holding 12.6v) will not crank. No solenoid "click".almost feels like there should be one more detent on ign switch, or that the key is not, for some reason, energizing the elect switch portion of the ign......any suggestions as to where to start looking will be gratefully received.
Thanks, Nev
__________________
Nev
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page