Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-30-2003, 12:25 PM
87 300 SDL's Avatar
Registered User
Join Date: Jun 2003
Location: Atlanta
Posts: 55
Question Light Problems

My 87 300 SDL the passenger headlight seems to have gone out. When I interchanged the bulb with the working driver's side still didn't work. Placed the original bulb back in and checked to see if the high-beam works and it did. Also odd is that the driver side, side-marker seems to have stopped working also. It works when the turn signal is on, but not when the parking light. Checked the rear lights and they are working and all the fuses are ok. If anyone has any ideas/advice I would appreciate the help.
Reply With Quote
Old 09-30-2003, 02:28 PM
G-Benz's Avatar
Razorback Soccer Dad
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
My first guess is that a ground lead has disconnected somewhere...with the interconnectivity of a typical automotive lighting system, one bad lead can create a bunch of weird lighting failures.
2009 ML350 (84K) - Family vehicle
2001 CLK430 Cabriolet (71K) - Wife's car
2005 BMW 645CI (124K) - My daily driver
2012 Mustang V6 (60K) - Daughter's car
Reply With Quote
Old 10-01-2003, 01:58 AM
haasman's Avatar
Registered User
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,096
First thing I would do is open the fuse box and spin all the fuses to ensure good contact. They often times get corroded at their ends. If they all look corroded, spend the time to clean both contacts. Use either WD40 or dielectric grease (both sparingly).

Check your bulbs carefully. Make sure you are using recommended bulbs. Sealed beams are not so critical but all others are. Look for corrosion on the bulbs. Use something to clean them off if necessary such as fine steel wool.

If a dealer isn't close by you can order through this site or go to an auto supply store that carries bulbs that have an OEM rating.

You owners manual will also typically list bulb ratings and specs.

Keep us posted,

'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
Old 10-29-2003, 10:06 PM
87 300 SDL's Avatar
Registered User
Join Date: Jun 2003
Location: Atlanta
Posts: 55

Sorry for the late update. I finally managed to getting around to cleaning the connections on the headlight and the corner light on the driverside. The headlight works fine now, but can't say the same for the corner light. Not sure what else could be wrong. Only other thing I can think of is their is a problem with the grounding of the wire. If anyone has the electrical diagram for an 87 300 SDL, could you send it to me.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:29 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page