Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-04-2003, 09:30 AM
Posts: n/a
Blower switches off on 190 E

1988 190 E 2.6L w/ 5-Speed. Well, Fritz is on the fritz. When the car is first started, all the heating controls work. After five minutes, it shuts down. If the heat is on and the blower on, say, the third level, it runs until it just stops - no blower. Start it up again after a five minute break, and all is well - for another five minutes. The blower does squeel a little bit (now and again), I know I have to lpull it and ube it or replace it, but if there was a problem with that, won't it just lock up/freeze up on the bearings and never work again? A new blower module was put in the dash within the last year. When it works, it works. Then it stops. Any ideas?
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:02 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page