Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-04-2003, 09:21 PM
Registered User
 
Join Date: Jan 2003
Posts: 18
Unhappy coolant leakage

hi,

i need some help on detecting my problem. this morning i was driving my 94 e320 wagon into a friend's driveway and i hit something underneath, and then my coolant lamp went on and saw the coolant leaking from the driver's side of the oil pump. does anybody know what's the problem? and if it is something i can fix myself?

thanks a lot,

carlos.
cotovelo@yahoo.com
Reply With Quote
  #2  
Old 10-05-2003, 12:37 AM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 19,751
My guess is the water pump's tired. It's not that difficult a job but whether or not you can do it is up to you. It could also be something else so don't order a new water pump just yet.

Sixto
95 S420
91 300SE
87 300SDL
83 300SD
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page