Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-04-2003, 08:21 PM
Registered User
Join Date: Jan 2003
Posts: 18
Unhappy coolant leakage


i need some help on detecting my problem. this morning i was driving my 94 e320 wagon into a friend's driveway and i hit something underneath, and then my coolant lamp went on and saw the coolant leaking from the driver's side of the oil pump. does anybody know what's the problem? and if it is something i can fix myself?

thanks a lot,

Reply With Quote
Old 10-04-2003, 11:37 PM
sixto's Avatar
smoke gets in your eyes
Join Date: Jun 2000
Location: SF Bay Area
Posts: 18,745
My guess is the water pump's tired. It's not that difficult a job but whether or not you can do it is up to you. It could also be something else so don't order a new water pump just yet.

95 S420
91 300SE
87 300SDL
83 300SD
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:54 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page